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1 Introduction

This document describes how to exchange information between Mantis Bug Tracking and IRQA. Through
the import/export capabilities of both tools it is possible to gather Mantis” elements into an Excel
document that may be imported later into IRQA.
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2 How it works?

First of all we will export the desired issues from MantisBT to MS Excel (through the CSV export option).
Then we will be using the IRQA Import Tool in order to import all the issues from the excel document to
IRQA.

2.1 Export elements from MantisBT

Starting in Mantis, we select the option “View Issues” to get a list of the different issues. From this view it is
possible to apply filters or the different fields and attributes. As the export option will export only those
elements currently displayed we can use this filter to ensure that only the desired elements are exported,
for example, we are going to export only the elements in status “new”

-~
Anonymous | Login | Signup for a new account 2010-08-31 07:20 EDT Project: | AllProjects =3
‘ Main | My Yiew | ¥iew Issues | Change Log | Roadmap | Dacs | Wiki | Biling lssue #
Reporter: Monitored By Assigned To: Cateqgory: Severity: Resolution: Profile:
any any any any any any any
Status: Product Build: Product Wersion: Fixed in Wersion: Priority: Target Wersion:
new any any any any any
Show: Miew Status: Show Sticky Issues: Changedihrs): Use Date Filters: Relationships:
50 any Mo & Mo any
Platfarm: os: 0% Wersion: Tags:
any any any
Sort by Last Update Descending Project: current
@ Search: [ Simple Filters ] [ Create Permalink ] [Reset Filter] hd
Viewing Issues {1 - 50 / 84) [ Print Reports ] [ CSY Export ] [ First Prev 1 2 Mext Last ]
P ID uss$ # 0 Category Severity Status Updated¥ Summary
£ 0009234 [CD)tET”;Dr] major new 2010-08-30  Budget Analysis Doesn't print the BUDO204 and BUDODZ0B Formats
£ 0003471 uUsgs 1 [%] crash new 2010-08-26  When I flapped my arms, a flash flood happened in my home state
0009202 (Dema] i 2010-08-25
ther minor new aaa
[Cema] .
. Q002200 GUL minor new 2010-08-25  FFF
0009181 (Dema] minar new 2010-08-20  |a test
Other
[Cemo] i _QE- FRTPITITIITITT
0003484 1 ST minar new 2008-05-22  7P77RPRYIRRIT
0003474 2 [Cﬁ'] minagr new 2008-05-21  Testing preservation {or not) of formatting when paste in code
0003463 (Dema] minar new 2008-05-21  test mantis
GUL 2

Once the filters have been applied, simply click on the [CSV Export] option. This will create a .csv
document (anonymous.csv by default). Note that it is possible to extract the elements directly to .xls
(Excel) if the Print Reports option is selected, however this option won’t be as friendly as the CSV option in
order to later import the document into IRQA.
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2.2 Convert the .csv document into .xlIs

Note: This section descries the way to import the document into Excel 2003. Depending on the version of
MS Excel you’re using, you may find some minor differences in the import process or in the dialog order,
however the min steps (selecting a character as separator and so on) remains the same

Open a blank excel document and select the option “Data>Import External Data>mport Data...” from
the Data menu.

Diaka | Team ‘Window  Help

(24 sort... | |l 4 100% « @ ! i Arie
Filter g lﬁ Links and Attachments !
Subkokals. .

Walidation. .. i | | J | |

Texk to Columns. .

i2| PivotTable and PivatChart Report, .,

| Impart External Data » m A ImportData, ..
Lisk r Ga Mew Web Query...
oML P | 4 Mew Database Query...
Refresh Data i Edit Query...
3 ‘M [aka Range Properties. ..
ol Farameters...

Now follow the Wizard with the following options:
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Text Import Wizard - 5tep 1 of 3

The Text Wizard has determined that vour data is Fixed Width.

IF this is correct, choose Mext, or choose the data type that best describes wour data,
Criginal data bvpe
Choose the file bype that best describes vour data;

(%) Delimited - Characters such as commas or tabs separate each Field.
() Fixed width - Fields are aligned in columns with spaces between each field,
Skart import at row; 1 e File arigin: Windows (ARSI w

Preview of file C:\Documents and Settings\BerengenalDeskiopl IROA. . \anonymous, csy.

Id,Project ,Beporter Assigned Tu:u,Prinrit]r,Severity,Repruducihil:iJ'A
nao02z35  emo, TestPourNous, ,norwal ,minor hawve not tried, ,none, 0t]
N002234 ,Deno , mikecquenther , ,imwediate major ,always, ,none , Other , 2
NO09233, ewo , Bqdw, ahoffrner norwal mihor , sometimes, 1. 2 none, Othe
NO09z201 , ewo , aaptioot, Sqdw_ norwal  winor N8, none , Website Z010-0

?

Firish

A.|m|#|w|N|H

Cancel

From this first dialog select the option “Delimited” and click on Next>

Text Import Wizard - Step 2 of 3

This screen leks wou set the delimiters your daka contains, You can see
hiows wour kext is affected in the preview below,

Delimiters _ [] Treat consecutive delimiters as one
[]1ab [ semicalon [w]ici ;
[Jspace  [] other: Text qualifier: b

[Daka preview

Froject [Feporter s=signed To [Priority everity [Peproduc -
Pz35 pemo estPFourNous hormal inor awe not
P34 Peno ikeguenther fmmediate wpajor lways
P33 peno opclur offrner hormal inor ometine
201 Pemo apnoot cfclur hiormal inor SR w
< >

Cancel ” < Back “ Mexk = H Eirish

From the dialog above select “Comma” as the delimiter and click on Next>
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Text Import Wizard - 5tep 3 of 3

IRQA integration with MantisBT

This screen leks vou select each column and set
the Daka Format,

'General' comverts numetic values to numbers, date
values to dates, and all remaining values ko ke,

Data preview

Colurnn data Farmak

(%) General
() Text
{:} Date:

) Do not import column (skip)

Dipy W

L“vens.r.al Conoral Conergl GConcr;
eporter ssigned To [Priority Pewerity [Fepro 3
estPourNous hiormal inor hawve 1
oo pwikegqisnther Humediate pajor luwray
[ ey of frier hiormal inor omet
paprnoot ofclnr hiormal inor fFa w
£ ?

Cancel ][ < Back

Finish

Import Data

Where do wou wank to put the data?
(%) Existing worksheet:

) Mews worksheet

In this late dialog no option needs to be modified. Click on Finish

Now you need to specify where the elements will be Imported in the excel documents. (By default the
selected Cell)

k.

X

Click Ok and you will get a sheet similar to this one:
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B3 Microsoft Excel - Book1

E_] File Edit Miew Insert Format Tools Data  Team ‘window  Help

NN~ BN R WA S RN A RS R

1
=)
1
=
Ry
=
1

Bl st | R Ge iblish @l Refresh Gl C
D13 * B uls
e 2 I D ETE G I H | | [0 ] K [ L ] M
1 [ld  ProjectReporter Assigned To Priority | Sewverity Reproducibility Product Versior Projection  Category Date Submitted ETA 0s
2 9235 Demo  TestPourhous normal minor  |have not tried none Other 31/08/2010 none
3 |9234 Demo  mikeguenther immediate major  |always none Other 30/08/2010 none
4 9233 Derno Sdw ahoffner normal minor | sometimes 1:2 none Other 30/08/2010 none
5 |9201 Demo aapnoot Sydw normal mingr WA nane Website 25/08/2010 none
| B 9208 Demo  veritoss veritoss none minor |random 1 none Other 250842010 none
| 7 19227 Demo  amay 0 normal minor  |always i none Gul 29/08/2010 none linuz
8 |A896 Demo  brueller 1111 low trivial randam none GUI 07/05/2009 none
9 9225 Demo jasanchez Jjasanchez normal minar  have not tried none Other 2706/2010 none
109216 Demo  jtejada rkwiathowski normal minar have not tried none GUl 26/08/2010 none
119223 Demo  test99199 z2772Z normal  trivial  always 1.1 none Yebsite 27/08/2010 none Windows XP
1219222 Demn  jeevesh O high major  |always 1.0 none GuUl 27/08/2010 none Windows xP
139221 Demo_ tocs tocs normal minor  |always 1.2 none Other 27/08/2010 none
| 14 19220 Demo  antara21B tocs normal minar  have not tried none GUl 2706/2010 none
| 18 19219 Dema  thyspir ksarm high major  randorm 1.0 none GUI 27/08/2010 | none
169218 Demo  testuser?6 testuser? normal minor  |have not tried none GUI 27/08/2010 none
17 |9217 Demo  purva 9 normal minor | sometimes none Website 27/08/2010 none windows
|16 9214 Demo uls luls Jurgent minor |ahways 12 none Website 26/08/2010 none weasd
1913471 Demo Dan Aguinas immediate crash  unable to reproduce 1.0 nane GUI 21/05/2008 none Truth, Beauty and Ligt
2019209 Demo  rob123321 aikis1 immediate crash  have not tried none Other 25/08/2010 none
|21 |9205 Demo  veritoss veritoss normal minor KA 1.1 none Other 250842010 none windaws xp
| 22 1910 Dema  roh123321 jnewhigin immediate crash  |have not tried none Other 25/08/2010 none
| 239207 Demo  veritoss ebarcsay normal minar | RAA ] none Other 25/08/2010 none
24 19206 Derno  veritoss ebarcsay normal minar | MAA 1.1 none Other 265/08/2010 none
259204 Demo  mrcoolice 1 narmal minor  unable to reproduce 1.2 none GUI 250842010 none My own
26 | 9203 Demo  roy_tate roy_tate normal minor  |unable to reproduce 1.2 none Gul 25/08/2010 none
27 | 7916 Demo  rfaster Tomda31589 urgent minor  |always none Other 02/03/2010 none
209202 Derno test111 normal minar  have not tried none Other 25/08/2010 none
2919200 Derno alpana_04 lowy minor  (unable to reproduce none GUI 25/08/2010 none
| 30 | 9180 Demo  cdussall Jjaystemet normal minor  |have not tried none Wiebsite 20/08/2010 none
| 31 | 8053 Demao  xcarval wcarval high major  |always 1 none Wehbsite 23/03/2010 none AlX
|32 |9158 Demn  stefanie 1036312 low trivial sometimes 12 none Website 24/08/2010 | none
|33 |6054 Demo  demo_account_pm wiglot high feature | MNAA 1.2 tureak GUI 23032010/ 1 day  WWIN
34 |6849 Derno  rameshe rayliang nartmal minor | sofmetimes hone GUl 25/09/2009 none
359184 Demo  marceliz 12345678 urgent major  |sommetimes nane Website 23/08/2010 | hone -
W 4 » n\\Sheetl Sheet2 £ Sheets / |< >

Ready

Note: | have highlight the first row with bold in order to make it more readable

Finally save the document as an xls file and it will be ready to be imported into IRQA.

2.3 Attributes creation in IRQA

Now that the document is ready for importing, there is one additional step that needs to be performed. It
is necessary to manually create the attributes that will be imported from the excel document in IRQA.
Later, those attributes will be fulfiled with the information from the excel document.

Note: Take into account that this step is only needed if the destination project doesn’t contain the
attributes. Once created, it is possible to import elements from Mantis as many times as needed.

Enter in the Attributes Type view from the “Engineering Process > Analysis > Attribute Types” menu

IRQA Integration wit MantisBT August 2010 www.visuresolutions.com 8
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Engineeting process | Tools  Reports  Wiew  Window  Help
8 Reaurements | v Ly |4 |y B B8~ - H : 4L Mo active black
| Analysis k| Tal Concepts » - P”d Les
Specification 4 Concept Diagrams
Testing k ta Akkribukes k
Inkegrations 3 Attribute Types | J | Predetermined
1 == [okives 4 Views Managermenk
;ii;iedz Def aulk

From this view, it is necessary to create the base type for the attributes that will be imported. Taker into
account that Text, Date, Boolean, Integer and Float types are already created in the project, so you only
need to define Enumerated (pick list) types.

Click on the Add Button ( # ) on the elements tool bar or select “Edit>Add Element” in the menu.

In the following dialog (New Type dialog) fulfill the Name, Base Type (Enumerated) and also the available
values. Those values need to be exactly the same as in Mantis, in order to perform the mapping.
Additionally it is possible to define a color for each value. To enter values, fulfill the Value text area and
select “Add Value”

M e |M_I,I Mew Enumerated Type]

Access Partition: | Drefault j

Fange

Base Type: | Enumerated j
Frarm: J
Tax J

-
Enurnerate
alue: 3 Add Y alue
Yalue List: Yalue |
1
: Lo+
3
Edit alues
] LCancel
Once finished, click on OK and the new type will be created.
IRQA Integration wit MantisBT August 2010 www.visuresolutions.com 9
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Once the needed types have been created (usually, only enumerated types need to be created) go to
the Attributes view from the “Engineering Process > Attributes” menu.

Engineeting process | Tools  Reporks  YWiew  Windaw
E Requirements | » F | E = [al =1
analysis » | al | Concepts »
Specification 4 Concept Ciagrams
Testing v & atributes [+
Inkegrations k| = Attribute Types 3
== [Matives r

From the attributes a new Attribute named as the excel columns that will be imported (which is the name
of the MantisBT Attributes) has to be created. For these attributes creation it is also possible to use the
types previously created.

Note: For more info about attributes or attribute types creation, please refer to the “IRQA User Guide”

2.4 Import the .xIs document into IRQA

The last step consist on importing the excel document into IRQA. Some work has to be done first into
IRQA. It is necessary to create one attribute for each attribute the user wants to import from the
document.

IRQA Integration wit MantisBT August 2010 www.visuresolutions.com 10
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= IROA 4

! Project Edit Engineering process  Tools  Reports  Wiew  Window  Help - =
:[#r Current E.ﬂ EH E L !if,iz!

0 W B = E'—E

Properties

- [4.1 Tutorial - MantisBT Test [ ADMIN ) : Attributes [18) “Default™]

Mame

fssigned To ; ~
Cateqary Dietail: l Scnpe] Related Elements] Ualues] "v"ersi-:uns]
Drake Submitted
ETa Attribute Author: Creation D ate:
Fiscerd ir Yersio |ADM|N 8 |2?£EIE£2IZI‘I 010:26: 24
05 Active Version Author: Active Yersion Date:
05 Yersion |.-‘-‘-.DMIN = |2?HDB£2EI'I 070:26:34
Platfarm Checked aut by:
Pricrity |.-‘-‘-.DI'-1IN a2
Produck Yersi
Pm. uu:tl BrEen Acceszz Partition:
rajection
Default -

Reporker | =t J
Reproducibilty Attribute Data
Resolution
Severity [ Multivalued [ Required
Skakus Type:

|DATE | TupesView B
View Skat

eSS Default W alue:
pddvale | v
< |

Ready ROWS MLIM

Not only attributes but also types (especially for enumerated attributes) need to be created.

Once created, click on Project>Import option in the Project menu. Select the word document and click
on next.

IRQA Integration wit MantisBT August 2010 www.visuresolutions.com 11
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g2 [RQA 4 Import Tool - Capture configuration

rSelect capture configuration

(%) Mew canfiguration

) Usge previous configuration

-Capture configuration

Marme Description
cpomfi
Mantis Configuration bo import From a mankis doc. ..
Runs
Web

Configurakionl

Cancel ] [ Help ]

Frevious ” Mext ]

Select new configuration from the Configuration Selection dialog.

fiE M5 Word Tables/M5S Excel Import - Import elements

-Select import elements

Capture "Requirements”

[ Capture "Services"

[] capture "Test scenarios”

[ Cancel ] [ Help ]

Frevious ][ M et ]

Select Capture “Requirements” from the Import elements dialog.

Now perform the mapping between the different columns that want to be imported and the attributes
into IRQA. Take into account that this mapping only need to be performed the first time, for later imports

we will save this configuration and wiill skip this part.

IRQA Integration wit MantisBT
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fif MS Word Tables/MS Excel Import - Capture configuration

Reguirernents | Senices | Test scenarios |
Sheets containing reguirements Sheet2
Sheet3
[ Use Capture Area
Start tag End tag
~Capture field
rReguirerment hierarchy
[ capture hierarchy Level Column
Mumber of levels |:
Predefined attributes Attributes
IRGA Field Column Type Column
Code |1d | | Attribute “ | Resolution v~
Mame Summary hd Attribute W05 b d
w | | Attribute | Assigned To w
Elocks | | | Attribute “ | Fixed in Yersion v
Attribute “ | Updated w
Attribute “ | Projection [ —
Attribute v | ETA w
Attribute | 05 Yersion w
Attribute W | Status w
Attribute | Dake Submitted V|
eronaue [ e | [(Skncoms |

In this case we have mapped the IRQA Name with the Summary; it is also possible to map it with the
description, for example.

Click on next, and click again the next dialog. Now the import tool will compare the elements being
imported with the one existing into IRQA. If this is the first time you perform the import, all elements will be
marked as new.

IRQA Integration wit MantisBT August 2010 www.visuresolutions.com 13
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£ [ROA 4 Import Tool - Captured elements

| Raguirements:| Senices | Test Scenarios|
-Captured elements

Show Al v sl | [ Mone
- Code Mame Status Farent
9235 Test456 MEW ~
9234 Budget Analysis Does. ., REW ---
9202 aaa REW --- -
9200 FFF MEW
9151 la test MEW
3484 TR ME'WY ---
3474 Testing preservation ... ME'WY ---
3471 When I Fapped my ar... ME'W -
3465 test mantis REW ---
3458 jhikhlk =
3453 test MEW
3452 kesting the new incident MEW ---
3443 kest mc REW --- w

~Existing elements with changes

(%) Create new version ofthe element

() Create copy with '=original_code= - COPY' code Doiff

[ Owerwrite element if check in is not possihle

[ Cancel ] [ Help ] [ Export To G5 ] [ Frevious ][ [+ et ] [ Skip Config
Select the elements that will be imported and click on next.
IRQA Integration wit MantisBT August 2010 www.visuresolutions.com 14

Copyright 2010 © Visure Solutions, S.L. All rights reserved



%Su re IRQA integration with MantisBT

the requirements company

ey

£ IRQA 4 Import Tool - Captured elements location

Reguirerments | Services | Test scenarios || Attributes & Blocks

rSelect lacation for captured elements

ACCESS paritian |Default w

[]Include in blocks

Available blocks Associated blocks

[]Include in domains

Associated domains
Available domains

Cancel ] [ Help ] [ Frevious ][ Insert ]

From this Dialog users may specify (through the access partition) the rights for the elements that are
going to be imported and also allocate them into a block (for example, Mantis block or Issues block).

To finish, click on Insert. Now it is also possible to save the configuration for alter uses. It is recommended
to do it in order to skip the attributes mapping.

IRQA Integration wit MantisBT August 2010 www.visuresolutions.com 15
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i project Edt Engneeringprocess ook Reports  Wew Window Help

ird Current ! i g | i I3 Wl - l i Mo active block - ! E
- - ndLevel]| -

s i il

B BB = =] b’ |
Code | Hame Assigne. .. | Category |Dake Submitted [ETA Fized in... |05 05 Version | Platform  |Updated | Priority | Product Version | Proje... |Reporter | Reproducibility Resolu... | Sevarity Status ¥4
3245 testreport Gt 1504200 none 15/04j2008 normal none  kriegs have not tried open minar new p
3253 Programm geht ned - Wergwetfen? Geschisse schon wieder nex Gt 16/04i2008 none 16/04/2008 high none  stefano always open crash new p
3259 bla GUL 16/04j2008 none 16/04/2008 normal none  niedbalski  sometimes open trivial new p
3262 121 =)} 16/04j2008 none il 6.0 Smartp... 16/04/2008 normal none  mirakle have not tried open minor new p
3271 asdfasdfasdf Other 17/04i2008 none asdf asdf asdf 17/0402008 low 1.2 none  vajapeye  someimes open trivial new  p
3276 Test Bug Gt 16[04i2005 none 16[04i2008 normal none  franka sometimes open Erivial new p
3330 test Other 29/04/2008 nione 29/04/2008 normal none  macklus have not tried apen rinar new p
3427 aaa Other 13/05)2008 none 13/05/2008 normal nong n26E31387  have not tried open minor =0 P
3443 test mc =)} 17/05j2008 none none 18/05/2008 none  roney always open feature new p
3452 testing the new incident Other 19/05j2008 none 19/05/2008 normal none  bwagnet  have nok bried open minor new  p
3453 test Wehsite 1905/ 2008 none 190512008 normal none  turash-da3Z? abways open minar new p
3458 jhkihk Other 20/05/2008 nione 20/05/2008 normal none  shivanand  have not tried apen rinar new p
3469 test mantis (=N} 21/05/2008 none 21/05/2008 normal none barommes  have not tried open minor =0 P
3471 When I flapped my arms, a flash flood happened in my home state =)} 21/05/2008 none Truth, B... w1.0 Earth 26/08/2010 1.0 none  Dan Aquinas unable to reprod... open crash new p
3474 Testing preservation (or not) of Formatting when paske in code Other Z1J05(2005 none 2Z1J05(2008 normal none  Dan Aquinas NiA open minor W p
3484 FIPITRIIIITITY Cther Z22[05/2008 none Z2[05/2008 normal nane mail5317031 have not tried opaEn minor ey p
9181 latest Other 20/08/2010 none 20/08/2010 normal none  bhob have not tried open minor new p
9200 FFF =)} 25/08/2010 none 25/08/2010 low none  alpana_D4  unable to reprod... open minor new  p
9202 zaa Other 25/08/2010 none 25/08/2010 normal none  testill have not tried open minor new p
9234 Budget Analysis Doesn't prink the BUDOZ0A and BUDOZ0B Formats Other 30/08{2010 none 30/08(2010 none  mikeguent... always open major W p
9235 TestdS6 Gther 31082010 none 1082010 normal none  TestPaur... have nok bried open minar new p
2
Ready ROWS MUM
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